Knowledgebase
Why does my NAS not have support for Kodi 14.x?
Posted by Yvon Lei on 07 May 2015 13:53

Due to hardware related limiation the N2520 N2560 N4520 N4560 N2800 N4510U N4800 N5550 & N7510 support up to XMBC (13.x) only, and have no Kodi 14.x or further version support.

 

 

(31 vote(s))
Helpful
Not helpful

Comments (0)